Add your comments here...
Why not name them operator+(), operator*(), etc.?
The example is wrong: the comment lines should say // overloads (a/i) and // overloads (i/a).
Why not allow globally defined operator overload functions?
The example is wrong: the function should be opAdd instead of add.
Why not use operator names like __add__ and __div__ instead of add, div, etc.?
This question should be rephrased.
Corresponding page in the D Specification